FogBugz Technical Support

A forum for technical support discussion related to Fogbugz.
The current FogBugz Knowledge Base can be found at http://help.fogcreek.com/fogbugz.

Posts by Fog Creek Employees are marked:

Documentation
Release Notes
Network Status

importBugzilla gives error: First node not

...not what?

Hi,
we are new FB 4.latest customers and attempting to import Our bugzilla data into a new FB install.
On the first attempt, the apache logs on the Bugzilla server  showed it was retrieving bugs but not XML (ah, we're running an old 2.16.x version - lets upgrade Bugzilla to get off it !! :)
So upgraded to the latest Bugzilla 2.20 - now the importBugzilla script is getting XML output, but still gives the same error (I added the docnodename is debug line - showing the script is getting NULL for the doc->nodename):

Importing Bug: 1...
docnodename is ""
First node not bugzilla
Importing Bug: 2...
docnodename is ""
First node not bugzilla
Importing Bug: 3...
docnodename is ""
First node not bugzilla
Importing Bug: 4...
docnodename is ""
First node not bugzilla
Importing Bug: 5...
docnodename is ""
First node not bugzilla

Any help appreciated!
Fletcher Cocquyt Send private email
Tuesday, January 24, 2006
 
 
PHP or ASP?
Michael H. Pryor Send private email
Wednesday, January 25, 2006
 
 
its the importBugzilla.php which redirects to
default.php?pg=pgImportBugzilla& on RedHat Linux php 4.4.2

Just added the dom configure options:
--with-dom --with-dom-xslt --with-dom-exslt --with-zlib-dir=/usr/lib

and re-compiled php, reinstalled, re-started apache

But no change.

thanks for any tips!
Fletcher Cocquyt Send private email
Wednesday, January 25, 2006
 
 
What does the beginning of the $sxml variable look like?
Michael H. Pryor Send private email
Wednesday, January 25, 2006
 
 
Added this debug:

 showerror( "sxml is \"" . $sxml . "\"")  ; 

and got:

sxml is "  1  2002-11-09 14:43  Test  2004-01-23 14:21:51  1  1  1  Unclassified  Pacific Free Clinic  database...

sxml is "  2  2002-11-14 09:58  AMCAS database  2004-06-10 15:50:31  1  1  1  Unclassified  MeSA2  +Project r...

thanks
Fletcher Cocquyt Send private email
Wednesday, January 25, 2006
 
 
You'll have to paste the source...

since you are writing <tags> to the browser, the browser isn't showing you the full xml (do a view source and you'll see what I mean)
Michael H. Pryor Send private email
Wednesday, January 25, 2006
 
 
Now its giving me "Bug Not Found" - here is the source:

<font color="red">sxml is "<bugzilla version="2.20"
          urlbase="http://irt-dev-bugs.stanford.edu/bugzilla.new/"
          maintainer="pconstantinou@stanford.edu"
          exporter="fletcher.cocquyt@stanford.edu"
>

    <bug>
          <bug_id>1</bug_id>
         
          <creation_ts>2002-11-09 14:43</creation_ts>
          <short_desc>Test</short_desc>

          <delta_ts>2004-01-23 14:21:51</delta_ts>
          <reporter_accessible>1</reporter_accessible>
          <cclist_accessible>1</cclist_accessible>
          <classification_id>1</classification_id>
          <classification>Unclassified</classification>
          <product>Pacific Free Clinic</product>

          <component>database</component>
          <version>1</version>
          <rep_platform>PC</rep_platform>
          <op_sys>Windows XP</op_sys>
          <bug_status>RESOLVED</bug_status>
          <resolution>FIXED</resolution>
Fletcher Cocquyt Send private email
Wednesday, January 25, 2006
 
 

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
 
Powered by FogBugz Bug Tracking and Evidence-Based Scheduling.