FogBugz Technical Support

A forum for technical support discussion related to Fogbugz.
The current FogBugz Knowledge Base can be found at http://help.fogcreek.com/fogbugz.

Posts by Fog Creek Employees are marked:

Documentation
Release Notes
Network Status

FogBugz *requires* php version 4.3.10 or greater

I had Fogbugz 3 running fine on the server.  I stopped doing development for a number of month and quit using it.  I eventually wne tin and deleted the files under the web directories and the /opt.

As you can imagine, I started developing again and came back.  I got V4, dropped it in /opt and run the install.

I then got this message: FogBugz *requires* php version 4.3.10 or greater!  That's funny, I'm running 4.3.2.  Any ideas what could be causing this problem?
Jim Pringle Send private email
Tuesday, December 27, 2005
 
 
Isn't it because (with PHP's versioning system) 4.3.2 actually is older than 4.3.10? (2<10)
Dimitri@NL Send private email
Tuesday, December 27, 2005
 
 
No, the reason is because there was a giant security hole in PHP and all versions below 4.3.10 are affect so we changed the installer after that to require 4.3.10.

Running without this version of PHP on your machine is not recommended.
Michael H. Pryor Send private email
Tuesday, December 27, 2005
 
 
You're both right! 4.3.2 is older than 4.3.10 (that reads four-three-ten, not four-three-one-oh), AND 4.3.2 has a big 'ol security hole, which is why FB 4 requires the upgrade.

4.3.2 was released in May of '03, 4.3.10 in December of '04.
Brett Kiefer Send private email
Monday, January 9, 2006
 
 

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
 
Powered by FogBugz Bug Tracking and Evidence-Based Scheduling.