FogBugz Technical Support

A forum for technical support discussion related to Fogbugz.
The current FogBugz Knowledge Base can be found at http://help.fogcreek.com/fogbugz.

Posts by Fog Creek Employees are marked:

Documentation
Release Notes
Network Status

FogBugz Email Setup via Exchange w/ Pop3

I am having trouble setting up email send/receive functionality.

We use hosted MS Exchange that has Pop3 available.

1) I configured the site smtp and mailbox using the exchange account we created for FogBugz and associated pop3 settings.
2) Logged into FogBugz and selected an already open bug.
3) Clicked forward, sent an email to several people. Note, there are two accounts available in the from DDL (the issues account i setup in FogBugz and my user's configured email account). I tried this send from both.
--> Mail never arrives in my email account.

I went to the site screen and ran the diagnostics. Everything was fine until it hit the email step where it failed.

Upon reviewing the failure info, it was clear that the diagnostics utility is attempting to access our hosted exchange system using the email address configured for the user that is actively running diagnostics -- NOT the smtp account i setup on the site page.

I went to the user options page and tried modifying the account to use the same email address that was configured for the site account. No dice; I received an infinite loop warning stating that I cannot configure a users email to be the same as the account email. I cancelled out of this page.

Undeterred, I went to the mailbox account and gave the mailbox that I had setup a different email address. I then returned to the user options page and was able to successfully setup the current user with the same email address that I configured on the site setup page.

I then returned to the diagnostics utility. Stepping through this utility I was able to send and receive email to the FogBugz account that we setup with our hosted exchange vendor.

I then logged into this account and found evidence of the this email in the account's inbox.

I guess I'm stumped. The diagnostic utility worked, so why can't I send email from within FogBugz?

Thanks.
Jake
Jacob Weir-Gertzog Send private email
Tuesday, December 27, 2005
 
 
What version of FogBugz are you using?
Michael H. Pryor Send private email
Tuesday, December 27, 2005
 
 
FogBugz Version 4.0.33 (DB 469)
Jacob Weir-Gertzog Send private email
Tuesday, December 27, 2005
 
 
Diagnostics.asp does not log into the SMTP server as the current fogbugz user.  It uses the SMTP user that you've set in the Site configuration page.  Maybe we could set up a f.c. copilot session and I can try to help you figure out what is wrong.  Email us via our mail page http://contact.fogcreek.com
Michael H. Pryor Send private email
Tuesday, December 27, 2005
 
 
FYI, I'm accessing Hosted Exchange 2003 accounts via POP3/SSL with FogBugz fine.

For SMTP I just our ISP's SMTP server.
Sam Chrisp Send private email
Wednesday, January 11, 2006
 
 

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
 
Powered by FogBugz Bug Tracking and Evidence-Based Scheduling.