FogBugz Technical Support

A forum for technical support discussion related to Fogbugz.
The current FogBugz Knowledge Base can be found at http://help.fogcreek.com/fogbugz.

Posts by Fog Creek Employees are marked:

Documentation
Release Notes
Network Status

RSS Feed issues with 4.0.33 update?

After upgrading today to 4.0.33, all my internal RSS Feeds no longer work properly. Here's the error given if I click on the RSS button to look at the feed on my browser.  Any idea if the RSS changes you guys made would have caused something like this?


The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


-----------------------------------------------------------

A semi colon character was expected. Error processing resource 'http://FogbugzServernameHere/FogBugz/default.asp?pg=p...

    <link>http://FogbugzServernameHere/FogBugz/default.asp?pg=pgList&pre=preLoadFilter&ixFilter=3</li...
Wiley Cox Send private email
Tuesday, December 20, 2005
 
 
The RSS feed for a saved filter or for a discussion group or for a single case?
Michael H. Pryor Send private email
Tuesday, December 20, 2005
 
 
RSS Feeds for Filters and single bugs.  Discussion group RSS works fine.  Trying to view a single case via RSS results in the window simply hanging, and not showing anything.  RSS for Filters displays the error shown above.
Wiley Cox Send private email
Tuesday, December 20, 2005
 
 
Weird. FF doesn't complain about it... but here is the fix:

In RSSForFilter change the line to:
StartFeed (Request("feed") = "atom"), sName, GetUrlPrefix() & "/default.asp?pg=pgList&amp;pre=preLoadFilter&amp;ixFilter=" & IntRequest("ixFilter")


The & needs to be &amp; in those two places.

The RSS feed for a singel case not coming up sounds like an issue with your web server...
Michael H. Pryor Send private email
Tuesday, December 20, 2005
 
 
I should have mentioned I was using IE, yeah.  OK, I'll try this and see what happens.  Was this a file that was changed in 4.0.33?
Wiley Cox Send private email
Tuesday, December 20, 2005
 
 
Yes, it was changed in 4.0.33
Michael H. Pryor Send private email
Tuesday, December 20, 2005
 
 
Your fix works for the filter issue.  However, aside from the upgrade to Fogbugz today, nothing on this server has changed, and the links from the filters into individual bugs still refuse to work.  Are you sure there isn't a "RssForBug" line somewhere that needs modifying?
Wiley Cox Send private email
Tuesday, December 20, 2005
 
 
Is your server on the internet so I can take a look?  I can't repro here...
Michael H. Pryor Send private email
Tuesday, December 20, 2005
 
 
Never mind about this bug thing.  I'm going to call it an "Act of God" issue, because just restarting my RSS program fixed the issue. :)
Wiley Cox Send private email
Tuesday, December 20, 2005
 
 
I'm experiencing the same problem. The RSS feed doesn't work for filters. Please explain your solution in more detail. What is "RSSForFilter"? Is it a file somewhere?
Todd Matson Send private email
Wednesday, January 18, 2006
 
 

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
 
Powered by FogBugz Bug Tracking and Evidence-Based Scheduling.