FogBugz Technical Support

A forum for technical support discussion related to Fogbugz.
The current FogBugz Knowledge Base can be found at http://help.fogcreek.com/fogbugz.

Posts by Fog Creek Employees are marked:

Documentation
Release Notes
Network Status

CVS checkin

I have setup CVS integration with FogBugz according to the setup guide.

CVS running on a unix box.
FogBugz running on a Windows 2003 Server box.

When I check in a test file, specifying a bug Id (15), the messages I get on commit indicate that FogBugz is being notified correctly of the checked in file.



This is the message I get from CVS on commit:
----------------------------------------------------------

In C:\cvs_temp\AbcamLIMS\java\com\abcam\lab\lims\sapphire\dao: "C:\Program Files\TortoiseCVS\cvs.exe" -q commit -m "BUGZID:15\n\nTesting Fogbugz integrations" Queries.java
CVSROOT=:pserver:glen@linux-01:/usr/local/cvsroot

Checking in Queries.java;
/usr/local/cvsroot/AbcamLIMS/java/com/abcam/lab/lims/sapphire/dao/Queries.java,v  <--  Queries.java
new revision: 1.12; previous revision: 1.11
done
ARG is AbcamLIMS/java/com/abcam/lab/lims/sapphire/dao
ARG is Queries.java,1.11,1.12
sARG is AbcamLIMS/java/com/abcam/lab/lims/sapphire/dao Queries.java,1.11,1.12
Attempting to add bug info for Bug ID #15...
Looking at Queries.java,1.11,1.12
Notifying FogBugz about %2FAbcamLIMS%2Fjava%2Fcom%2Fabcam%2Flab%2Flims%2Fsapphire%2Fdao%2FQueries.java version 1.12...
Using wget

Success, CVS operation completed
-----------------------------------------------------------



However, when I go to the FogBugz case (15), I do not get a "checkins" section for it.

Do I need to display that section in Fogbugz, or has it basically not worked?
I've tried to add the column to the display in the "Grid View", but "checkins" is not available to be selected.

Any ideas/suggestions would be grateful.

Thanks.
Glen Au-Yeung Send private email
Monday, September 10, 2007
 
 
I've just looked at a table in the FogBugz database called CVS, and it's empty. This suggests that it probably hasn't done the file association correctly. So it's basically not worked.
Glen Au-Yeung Send private email
Monday, September 10, 2007
 
 
Got it working.

Turns out I've not specified the url correctly to the FogBugz server in the perl script.
Glen Au-Yeung Send private email
Monday, September 10, 2007
 
 

This topic is archived. No further replies will be accepted.

Other recent topics Other recent topics
 
Powered by FogBugz Bug Tracking and Evidence-Based Scheduling.